Создание пользовательского интерфейса с применением макросов в приложении Excel icon

Создание пользовательского интерфейса с применением макросов в приложении Excel



НазваниеСоздание пользовательского интерфейса с применением макросов в приложении Excel
Дата конвертации08.11.2012
Размер115.91 Kb.
ТипДокументы

Создание пользовательского интерфейса с применением макросов в приложении Excel


Раздел: Преподавание информатики

Цель предлагаемого задания:

Активизировать и интегрировать разрозненные знания по отдельным темам, полученные при изучении электронных таблиц; провести плавное “погружение” учащихся в изучение нового серьезного материала по созданию макросов в приложении Excel и расшифровки команд, полученных с помощью MacroRecordera, и хранящихся в форме программ на языке VBA; ввести понятие объекта и метода и выполнить при этом задание, которое впоследствии может послужить примером для разработки автоматизированной информационной системы.

^ Прежде чем приступить к изучение объектно-ориентированного языка VBA я предлагаю изучить создание макросов и научиться применять их на следующей задаче.

Предложенную задачу можно представит как объединение 4 задач:

1. Хранение и обработка числовых данных в электронной таблице с применением относительных и абсолютных ссылок, а также математических и логических функций. В своем примере я привожу задачи по работе туристического агенства, отеля, книжного холдинга и фабрики по пошиву верхней одежды.

2. Проведение статистической обработки полученных результатов с использованием специальных встроенных функций. При использовании статистических функций мы их записываем с помощью MacroRecordera, то есть, сохраняем в виде процедуры.

3. Построение диаграмм и графиков по полученным расчетным данным в таблицах.

4. Создание пользовательского интерфейса (Меню), позволяющего объединить все решенные задачи (с применением макросов).

Ход урока

Объектно-ориентированный язык программирования Visual Basic for Application (VBA) является версией языка Visual Basic и предназначен для использования в среде приложений Microsoft Office (Word, Excel, Access и др.)

Существует достаточно простая возможность создания программы (макроса) на языке ^ VBA с использованием MacroRecorder.

MacroRecorder – это транслятор, который переводит все действия пользователя с момента запуска MacroRecorder до окончания записи макроса на язык VBA.

Макрос – это имеющая имя последовательность заданных пользователем команд, хранящаяся в форме программы на языке VBA.


I этап - Создание пользовательского интерфейса

Подготовка листа Excel для дальнейшей работы:

1. В рабочей книге должно быть 5 листов. Переименуйте листы следующим образом:

l Лист1 - “Меню”

l Лист2 – “Отель”

l Лист3 – “Фабрика”

l Лист4 – “Холдинг”

l Лист5 – “Турагенство”

2. С помощью коллекции WordArt подготовьте на созданном листе “Меню” надписи “Меню” и “4 задания”.

3. Вызовите на экран дополнительную панель “Рисование”.

4. Используя элемент “Автофигура” нарисуйте на листе одну кнопку (всего кнопок будет 4).

5. Используя контекстно-зависимое меню этого объекта, добавьте надпись на кнопке “Турагенство”.

6.  Измените, дизайн кнопки, т.е. поменяйте фон кнопки, а также начертание, название шрифта и размер букв надписи на кнопке.

Рис. 1. Так выглядит пользовательский интерфейс “4 задания”



II этап - Создание макросов.

1. Установим курсор на листе “Меню”.

2. Активизируем MacroRecoder с помощью команды Сервис-Макрос-Начать запись.
Появится диалоговое окно “Запись макроса”. Это диалоговое окно позволяет задать параметры макроса.

^ Рис. 2. Диалоговое окно “Запись макроса”



По умолчанию макросам присваиваются имена Макрос1, Макрос2 и т.д. Чтобы легче было распознать макрос, лучше присвоить ему имя, поясняющее его назначение. Присвоим макросу имя “Турагенство” и нажмем кнопку Ок. Появится плавающая панель инструментов с кнопкой “Остановить запись”. Теперь все производимые нами действия будут записываться до тех пор, пока не будет нажата эта кнопка.
^ Не выполняйте никаких лишних действий. Все ваши действия фиксируются и записываются. Надо выполнить только одно действие.

l Перейдите на лист “Турагенство”.

Остановите запись макроса, нажав на кнопку “Остановить запись”.

3. Просмотрите записанную программу. Для этого выполните команду Сервис-Макрос-Макросы. Созданная программа записалась в Модуле1.

Рис. 3. Главное окно редактора VBA



Таким образом, MacroRecorder записал нужную нам программу из одной строки:
Sheets(“Турагенство”).Select – выбрать лист “Турагенство”.

III этап - “Оживление” кнопок.

1. Для того чтобы эта программа выполнялась, то есть, происходил переход на лист “Турагенство” при нажатии на одноименную кнопку, выполните следующие действия:

l закройте окно редактора VBA;
l на листе “Меню” вызовите контекстно-зависимое меню на автофигуре с надписью “Турагенство”

^ Рис. 4. Контекстно-зависимое меню автофигуры “Турагенство”



l в появившемся меню выберите команду “^ Назначить макрос
l в окне “Назначить макрос объекту” выберите имя макрос “Турагенство” и подтвердите выполнение операции, нажав на кнопку ОК.
l снимите выделение с кнопки и проверьте ее работоспособность, щелкнув по ней.

2. Создайте и оживите оставшиеся кнопки пользовательского интерфейса.

IV этап Решение задачи на листе “Турагенство”

Постановка задачи

Сформируйте и заполните накопительную ведомость по продаже путевок туристической фирмой "Пять континентов" за май 2003 г.

Фирма имеет семь постоянных маршрутов. Цена каждого маршрута и количество проданных путевок представлены в таблице. Если количество проданных путевок в месяц по каждому из маршрутов более 50, то путевки, проданные сверх этих пятидесяти, реализуются со скидкой в 15% от указанной цены.

Рассчитайте по формулам стоимость всех проданных путевок; количество проданных путевок со скидкой; для путевок, проданных со скидкой, рассчитайте размер скидки в евро и итоговую выручку по каждому туру.

Подведите итог за месяц по всем графам таблицы: количество проданных путевок фирмой за месяц, стоимость всех проданных путевок без учета скидки, общая сумма скидки, итоговая выручка за месяц по туристической фирме. Расчеты производите в евро.

Определите максимальное количество путевок, проданных со скидкой.

Определите минимальную стоимость тура.

Рассчитайте среднюю скидку за проданные путевки.

^ Продажа путевок туристической фирмой

"Пять континентов" за декабрь 2003 г.

Наимено-вание маршрута

Цена за тур (в евро)

Кол-во проданных путевок

Стоимость проданных путевок (в евро)

Количество путевок, проданных со скидкой

Размер скидки за проданные путевки (в евро)

Итоговая выручка (в евро)

Египет

350

60













Испания

450

20













Кипр

290

25













Чехия

450

80













Греция

560

27













Англия

670

55













Мексика

1390

60













Итого:




Сумма

Сумма

Сумма

Сумма

Сумма

Постройте диаграммы:

1. Круговую диаграмму по графе "Количество проданных путевок".

2. Гистограмму по графе "Итоговая выручка".

Требования:

1. Процент скидки (15%) и пограничное количество путевок (50) вынесите в отдельные ячейки с комментариями.

2. При расчете количества путевок, проданных со скидкой, используйте логическую функцию ЕСЛИ.

3. Создайте макросы для расчета максимального, минимального и среднего значений. Нарисуйте автофигуры. Привяжите созданные макросы к этим автофигурам. А также создайте еще один дополнительный макрос и кнопку для очистки ячеек с результатами вычислений этих значений.

4. На листе “Турагенство” создайте кнопку для перехода на лист “Меню”.

5. Создайте копию листа “Турагенство”. Переименуйте лист в “Формулы” и выведите в созданной таблице формулы расчета.

Образец выполненной работы представлен на рис. 5. Работу выполнила ученица Ломоносовской школы 10 класса “В” Дубровская Ксения.

Рис. 5. Выполненная работа



Проверка выполненного задания

При проверке выполненного задания учащиеся должны представить:

1. Таблицу со значениями.

2. Таблицу с формулами (рис.6). Уметь объяснить работу формулы ЕСЛИ и применение абсолютной адресации в формулах.

Рис. 6. Выполненная работа с формулами



3. Показать текст макросов в редакторе VBA, созданных при нахождении статистических показателей.

Sub Средняя_цена()
Range("C14").Select
ActiveCell.FormulaR1C1 = "=AVERAGE(R[-11]C[3]:R[-5]C[3])"
End Sub

Sub Максимум ()
Range("A14").Select
ActiveCell.FormulaR1C1 = "=MAX(R[-11]C[4]:R[-5]C[4])"
End Sub

Sub ^ Минимум()
Range("B14").Select
ActiveCell.FormulaR1C1 = "=MIN(R[-11]C:R[-5]C)"
End Sub

Sub Очистка()
Range("A14:C14").Select
Selection.ClearContents
End Sub

4. Уметь объяснить адресацию ячеек в Excel. Для ссылок на ячейки используются два формата. Формат ^ А1 (ссылка состоит из имени строки и номера столбца). Формат R1C1 – этот формат мы видим в созданных макросах при нахождении среднего значения, максимума и минимума. В формате R1C1, после буквы “R” указывается номер строки ячейки, после буквы “С” - номер столбца. Например, абсолютная ссылка R1C1 эквивалента абсолютной ссылке $A$1 для формата А1. Для задания относительной ссылки указывается смещение по отношению к активной ячейке. Смещение указывается в квадратных скобках. Знак указывает направление смещения. Например, R[-11]C:R[-5]C) (фрагмент адресации взят из нашего макроса Минимум). Активной ячейкой в этом макросе является ячейка B14. R[-11]C – обозначает относительную ссылку на ячейку, расположенную на 11 строк выше в том же столбце, т. е. ячейку B3. R[-5]C) - обозначает относительную ссылку на ячейку, расположенную на 5 строк выше в том же столбце, т. е. ячейку B9. Таким образом, формируется диапазон В3:В9 для нахождения минимального значения.

На остальных листах также должны быть выполнены аналогичные задания. Условия задания в электронной таблице подбираются созвучно именам листов в созданной книге.

Например:

l реализация книг издательствами холдинга "Спутник" по кварталам за 2003 год и т.д.;

^ Этот материал можно использовать на факультативных занятиях, в классах с углубленным изучением информационных технологий, для выполнения проектов и курсовых работ.

Темой для проекта можно выбрать создание информационной системы “Торгово-закупочное предприятие”, в котором применение макросов необходимо, также как и написание программ на языке VBA. На рис.7 показан пользовательский интерфейс для названного проекта.

^ Рис. 7. Меню “Торгово-закупочное предприятие”



Рис.8 . Таблица с формулами

Продажа путевок туристической фирмой "Пять континентов" за декабрь 2003г.







Наименование маршрута

Цена за тур (в €)

Кол-во проданных путевок

Стоимость проданных путевок (в €)

Кол-во путевок, проданных со скидкой

Размер скидки за проданные путевки (в €)

Итоговая выручка




Скидка

Египет

350

60

=B3*C3

=ЕСЛИ(C3>$I$9;C3-$I$9;0)

=B3*E3*$I$3

=D3-F3




0,15

Испания

450

20

=B4*C4

=ЕСЛИ(C4>$I$9;C4-$I$9;0)

=B4*E4*$I$3

=D4-F4







Кипр

290

25

=B5*C5

=ЕСЛИ(C5>$I$9;C5-$I$9;0)

=B5*E5*$I$3

=D5-F5




Пограничное кол-во путевок

Чехия

450

80

=B6*C6

=ЕСЛИ(C6>$I$9;C6-$I$9;0)

=B6*E6*$I$3

=D6-F6




Греция

560

27

=B7*C7

=ЕСЛИ(C7>$I$9;C7-$I$9;0)

=B7*E7*$I$3

=D7-F7




Англия

670

55

=B8*C8

=ЕСЛИ(C8>$I$9;C8-$I$9;0)

=B8*E8*$I$3

=D8-F8




Мексика

1390

60

=B9*C9

=ЕСЛИ(C9>$I$9;C9-$I$9;0)

=B9*E9*$I$3

=D9-F9




50

Итого:




=СУММ(C3:C9)

=СУММ(D3:D9)

=СУММ(E3:E9)

=СУММ(F3:F9)

=СУММ(G3:G9)










Похожие:

Создание пользовательского интерфейса с применением макросов в приложении Excel iconExcel — это программа, предназначенная для создания таблиц, выполнения вычислений и анализа данных. Такие программы называются редакторами электронных таблиц. В приложении Excel
Такие программы называются редакторами электронных таблиц. В приложении Excel можно создавать таблицы, в которых автоматически будут...
Создание пользовательского интерфейса с применением макросов в приложении Excel iconСоздание формул в Excel Порядок ввода формулы
Вводить формулу надо со знака равенства. Это надо для того, чтобы Excel понял, что в ячейку вводится именно формула, а не данные
Создание пользовательского интерфейса с применением макросов в приложении Excel iconПрограмма Excel рассчитана на работу не только с цифрами, но и с буквами. Назвать Excel просто «электронная таблица»
Целью данной работы служит рассмотрение программы excel, её применения в различных областях жизни
Создание пользовательского интерфейса с применением макросов в приложении Excel iconЛабораторная работа
Создание и заполнение таблицы постоянными данными и формулами с помощью табличного процессора Microsoft Excel 2003
Создание пользовательского интерфейса с применением макросов в приложении Excel iconСоздание базы данных «Здоровье нации» с использованием возможностей Microsoft Excel
База данных – совокупность определенным образом организованной информации на какую-то тему
Создание пользовательского интерфейса с применением макросов в приложении Excel iconДокументи
1. /27.Excel.Bazy_dannyh_filtry/Практическая 27. Excel. Базы данных, фильтры.doc
Создание пользовательского интерфейса с применением макросов в приложении Excel iconСоздание теста в ms excel Введите вопросы теста по образцу
В строку Источник через точку с запятой без пробелов введите Выберите возможные варианты ответа (не номер правильного ответа, а сам...
Создание пользовательского интерфейса с применением макросов в приложении Excel iconГ. Л. Чжан Электронные таблицы Excel
Учебное пособие предназначено для индивидуальной формы обучения по теме «Электронные таблицы Excel»
Создание пользовательского интерфейса с применением макросов в приложении Excel iconExcel Программа Excel используется для обработки числовых данных по заданным формулам. Специфика работы с Excel заключается в том, что вычисления производятся с содержимым ячеек таблицы, в которых хранятся данные.
Программа Excel используется для обработки числовых данных по заданным формулам. Специфика работы с Excel заключается в том, что...
Создание пользовательского интерфейса с применением макросов в приложении Excel iconРабота с окнами графического интерфейса windows хр
Измените размеры нескольких окон и расположите их в разных местах экрана (мозаикой)
Разместите кнопку на своём сайте:
Документы


База данных защищена авторским правом ©lib.podelise.ru 2000-2014
При копировании материала обязательно указание активной ссылки открытой для индексации.
обратиться к администрации
Документы

Разработка сайта — Веб студия Адаманов